This project is read-only.

Naming: Specs vs. Code

Nov 23, 2011 at 6:34 PM

Since Jörg checked in much of the code before the specs were written, the code uses different names than the respective specs.

Following the DDD principles of having a ubiquiteous language (that should even be shared with the customer, although we need to translate the terms to German in our case), I think we should aim to use the same wording in the code and the specs. Therefore, I'd like to change either the specs to match the code or the code to match the specs.

Here's a list of differences in (code vs. specs):

  • RegisterSponsor vs.  EnterSponsor
  • Child vs. SponsoredChild (as opposed to an AssociatedPerson)

If nobody is opposed to it, I'll update the code to match the specs.

Nov 23, 2011 at 6:40 PM

The commands and events should have been just sample. Feel free to change the names.